
RETISTRUCT manual

David C. Sterratt

12th September 2020



2 Retistruct version: 0.7.3 , Date: 2020-09-12



Contents

1 Installation 5
1.1 Install the necessary system packages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

1.1.1 Ubuntu Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.1.2 Fedora Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.1.3 Mac OS X . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.1.4 MS/Windows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

1.2 Install the core RETISTRUCT package . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
1.3 Install the RETISTRUCT GUI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

2 Running RETISTRUCT 7
2.1 Preparing and opening the files for a retina . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
2.2 Reading files using the IMAGEJ ROI format . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

2.2.1 Reading in images comprising multiple fragments [Optional] . . . . . . . . . . . . 8
2.2.2 Specifying the scale . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
2.2.3 Specifying depth information [Optional] . . . . . . . . . . . . . . . . . . . . . . . . 8
2.2.4 Reading in data points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
2.2.5 Reading in data counts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

2.3 Reading in files using other formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
2.3.1 CSV format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
2.3.2 IDT format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

2.4 Editing the retinal mark-up . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
2.5 Editing metadata . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.6 Saving the markup and metadata . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.7 Reconstructing the retina . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.8 Assessing the quality of the reconstruction . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.9 Selecting viewing options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

2.9.1 Show . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
2.9.2 IDs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
2.9.3 Projection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
2.9.4 Transform . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

2.10 Exporting the plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
2.11 Saving the reconstruction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

3 Further topics 15
3.1 Accessing reconstruction data from R . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
3.2 Reading reconstruction data into MATLAB . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
3.3 Running a batch of reconstructions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

A The IDT Data format 19

3



4 Retistruct version: 0.7.3 , Date: 2020-09-12



Chapter 1

Installation

1.1 Install the necessary system packages

1.1.1 Ubuntu Linux

Follow the instructions at https://cran.r-project.org/bin/linux/ubuntu/ to obtain the latest sta-
ble version of R. For example, for Ubuntu 16.04 (Xenial) to download R from the Bristol UK mirror,
enter the following in a terminal window:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9

sudo apt-add-repository deb https://https://www.stats.bris.ac.uk/R/bin/linux/ubuntu xenial/

sudo apt-get install r-base r-base-dev libgtk2.0-dev libgl1-mesa-dev libglu1-mesa-dev

1.1.2 Fedora Linux

NOTE: these instructions have not been tested since at least 2015.
As root,

yum install R-core

yum install R-devel

yum install gtk2

yum install gtk2-devel

yum install mesa-libGL-devel

yum install mesa-libGLU-devel

1.1.3 Mac OS X

First install R for Mac OS X, available from http://www.r-project.org/. Under Mac OS X Leopard
and Lion, this should be sufficient.

Under Mac OS X 10.8 (Snow Leopard),

it may be necessary to install the following external packages:

• Xcode (free from App Store)

• Xquartz (http://xquartz.macosforge.org/)

• GTK (http://r.research.att.com/libs/GTK 2.18.5-X11.pkg)

Under Mac OS X 10.9 (Mavericks) or Mac OS X 10.10 (Yosemite),

See this issue on Github: https://github.com/davidcsterratt/retistruct/issues/4

1.1.4 MS/Windows

First install R for MS/Windows, available from http://www.r-project.org/.
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1.2 Install the core RETISTRUCT package

1. Start R

2. Type:

install.packages("retistruct")

The first time this runs, it should create a personal directory for R packages, and it will take a few
minutes to install some required packages.

3. Test that it is working as follows (from within R)

library(retistruct)

demo("retistruct.method")

If all is well, you should be prompted to press Return a few times and Figure 1 from the paper [1]
will appear (drawing the 3D renditions takes some time). There will be reports of warnings; they
are to do with printing the figures to files. You can view them by typing warnings().

4. A further test produces Figure 2:

demo("low.high")

5. A further (quite long-running) test produces Figure 6:

demo("figure6")

1.3 Install the RETISTRUCT GUI

If the previous step works:

1. Type:

retistruct()

2. Some more packages will be downloaded – this may take a minute or so.

3. If you are using MS/Windows, there may be an error message saying that libatk-1.0-0.dll is miss-
ing from your computer. Click on OK. Another message will appear, asking if you want to install
GTK+. Agree to this. After this has finished, quit R (without saving the workspace image) and
restart.

4. If all works, an interface window should appear. A number of sets of demonstration data are
available from the Demo menu item.



Chapter 2

Running RETISTRUCT

To start the program, start R. At the R prompt type:

library(retistruct)

retistruct()

A window should appear.

2.1 Preparing and opening the files for a retina

There are a number of types of information associated with a flat-mount retina that RETISTRUCT can
process:

• The coordinates of the outline of the flattened retina

• An image of the flat-mount retina (optional)

• The coordinates of labelled data points within the flat-mount retina (optional)

• The coordinates of labelled counts of data within the flat-mount retina (optional)

• The scale of the coordinates provided in the other files (optional)

To import this information into RETISTRUCT, for each retina, a directory should be created containing
files with the above information, as will be described below. At present there are three formats of
directory that RETISTRUCT can read. Most users will probably find the the IMAGEJ ROI format most
convenient.

2.2 Reading files using the IMAGEJ ROI format

This format allows you to load images of retinae whose outlines have been marked up in IMAGEJ. To
create the image and outline files for this format:

1. Create a directory to save the files created to.

2. Open up IMAGEJ (or FIJI).

3. Use File→Open to open the image.

4. Use Image→Scale to down sample so that the resolution is less than 1000x1000. (This is not
crucial, but will speed up things later.)

5. Save the down-sampled version of the image to the file name image.png in the directory created
in Step 1.

7
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6. Use the Polygon Tool ( ) to mark the edge of the retina. According to the IMAGEJ manual1: “To
create the selection, click repeatedly with the mouse to create line segments. When finished, click
in the small box at the starting point (or double-click), and ImageJ automatically draws the last
segment.

The points that define a polygon selection can be moved or deleted, and new points can be added.
To delete a point, click on it with the alt key down. To add a point, click on an existing point with
the shift key down.”

7. Open the ROI manager by selecting Analyze→Tools→ROI Manager.

8. Click on the Add [t] button.

9. Click on the More→Save button. In the Save selection. . . box that appears, enter the file name
outline.roi and make sure this file is saved to the same directory as the image.png file, i.e. the
directory created in Step 1.

10. Optionally mark up the optic disc in the same way as the outline. Save this ROI to a file called
od.roi in the same directory as image.png.

11. Open RETISTRUCT.

12. Click on the Open icon and select the directory containing image.png and outline.roi. The reti-
nal image should now appear, with the outline shown. By default the outline is in black. If this
isn’t visible against the image, press the Properties button in the interface (or select Edit→Properties),
and change the Outline colour.

2.2.1 Reading in images comprising multiple fragments [Optional]
Images from retinae that been cut into multiple fragments can also be loaded in. To do this, instead of
saving one outline.,save multiple ImageJ ROI regions from the same image in a file called RoiSet.zip

2.2.2 Specifying the scale
Optionally, the scale of the image can be specified by providing a file scale.csv in the same directory
as the image and ROI files. This file should contain two lines, the first with the heading Scale and the
second with the length of the side of a pixel in micrometres. For example:

"XY"

1.5

Note that for compatibility with older versions of Retistruct, this column can also be called “Scale”.

2.2.3 Specifying depth information [Optional]
A “flat-mount” needn’t be flat. If depth information is available, this should be supplied in the form of
a single-channel TIFF file called depthmap.tiff with the same dimensions as image.png. The value of
each pixel in the TIFF file specifies the height of the corresponding pixel in the image. The size of each
step in the Z-direction should be specified using an extra column “Z” in scale.csv.

Parts of the TIFF image will correspond to parts of the flat-mount that are empty; we refer to these
parts as the background. Typically the background is represented by a value of 0. There will be prob-
lems if the outline specified in ImageJ strays onto parts of the TIFF depthmap image, since it might
appear that there are very sharp jumps in the depth. To get around this problem, it is necessary to
specify the value of the background, so that RETISTRUCT can infer the depth of any background regions
that the outline strays onto by looking at the closest depths that are in the foreground. To specify the
background value, include a file depthmap.csv, in the following format:

"Background value"

0

If there is no depthmap.csv in this format, RETISTRUCT tries to infer the background value, giving a
giving a warning as it does so.

1http://rsbweb.nih.gov/ij/docs/tools.html
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2.2.4 Reading in data points

In general, the coordinates of data points are read in from a csv file called datapoints.csv. The two
cells of the first line of the file contain the name of the group of data points and the colour that these
should be displayed in RETISTRUCT. Marking up the points from the image in IMAGEJ will ensure that
the coordinates are in the same system as those used for the image and the outline. To do this:

1. Open the image used for marking up the outline (image.png) in IMAGEJ.

2. Threshold the image (Image→Adjust→Threshold. . . so that the labelled points are visible.

3. Select Analyze→Set Measurements. . . and make sure that Centroid is checked

4. Select Analyze→Analyze Particles. Make sure that Display results and Clear results are checked.
Click on OK.

5. A window entitled Results should appear. This contains the X and Y coordinates of the detected
points. In this window select File→Save as. . . and save the file as datapoints.csv.

6. Open this file with either EXCEL or OPENOFFICE CALC and remove all the columns apart from
the X and Y columns. Replace the X with the name of the data set and the Y with the colour it
should be displayed in RETISTRUCT.

7. Save datapoints.csv in the retina’s directory, along with outline.roi (and image.png if an im-
age is desired).

2.2.5 Reading in data counts

In general, the coordinates of data counts (counts of data at X, Y positions) are read in from a csv file
called datacounts.csv.

The two cells of the first line of the file contain the name of the group of data counts and the colour
that these should be displayed in RETISTRUCT.

Each subsequent row has three numbers: The first two columns contain the X and Y coordinates at
which the count was measured, and the third column contains the count at that location. It is important
to ensure that the coordinates are in the same system as those used for the image and the outline.

Save datapoints.csv in the retina’s directory, along with outline.roi (and image.png if an image
is desired).

2.3 Reading in files using other formats

2.3.1 CSV format

This is the same as the IMAGEJ ROI format, except that the outline is contained in the two columns of a
file called outline.csv. Each column should have a heading, e.g.:

"X", "Y"

1,5

10,76,

...

The optic disc outline can be supplied in a similar file called od.csv.

2.3.2 IDT format

This is the format used in Ian Thompson’s lab (see Appendix A). These files are contained in a directory.
To open the files corresponding to a retina, click on the open file icon, and navigate to the directory
containing the SYS and MAP files. On opening this directory, the retinal outline should appear in the
RETISTRUCT window.
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Figure 2.1: Adding a full cut. One full cut between the two upper petals has been added. The red
dashed line indicate the ends of the full cut, and the red highlighted edge indicates the edges of the full
cut.

2.4 Editing the retinal mark-up

After a set of files is opened, the Edit tab in the RETISTRUCT window will be open. Before the retina can
be reconstructed, you need to mark-up tears, full cuts and landmarks on the retina using the following
controls:

Add tear To add a tear, click on this button, then click on three points in turn which define a tear. The
order in which the points are added does not matter. Tears contained within a tear can be marked
up, but tears cannot cross over one another.

Remove tear To remove a tear, click on this button, then click on the apex of the tear (marked in cyan
on the plot)

Add full cut To add a “full cut”, i.e. a pair of corresponding edges of two fragments, click on this
button, then click on four points in turn which define a full cut (Figure 2.1). The order in which
the points are added does not matter.

Remove full cut To remove a full cut, click on this button, then click on any point on the full cut.

Move Point To move one of the points defining a tear or full cut, click on this button, then click on the
point which you desire to move, then click on the point to which it should be moved.

Mark nasal To mark the nasal pole, click on this button, then click on the point which is the nasal pole.
If the nasal or dorsal pole has already been marked, the marker is removed from the existing
location. The nasal pole should not be in a tear. If the nasal tear is placed within a tear, no error is
reported at this stage, but it will be reported later.

Mark dorsal As above, except for the dorsal pole.

Mark OD To mark the optic disc, click on the structure marked in orange which you think is the OD.
Once clicked on, the structure should become blue.
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Phi0 This determines the latitude of the rim of the reconstructed hemisphere. In mouse, it depends on
the age of the animal [1]. Ideally you will have measured or estimated this value from an intact
retina. The default value of 0 may lead to reconstructions that are not as accurate as they could
be, since the template that RETISTRUCT is trying to morph the flat-mount retina onto is not the
same as the original shape.

2.5 Editing metadata

You can also edit the following metadata:

Data/Flip DV Flip the DV axis to compensate for microscope orientation. Affects display of retinae.

Eye Specify whether the eye is Right or Left. Affects display of retinae.

2.6 Saving the markup and metadata

To save the markup, click on the “Save” button in the toolbar. This saves various markup files to the
directory containing the data files. This saved data can be used to reconstruct the retina using a batch
process (Section 3.3).

2.7 Reconstructing the retina

To reconstruct the retina, click on the “Reconstruct retina” button. This causes RETISTRUCT to perform
a (sometimes lengthy) sequence of operations:

Stitching Links between corresponding points on parts of the retinal outline contained in tears are
made.

Triangulation A triangular mesh is placed over the flattened retina

Initial projection to sphere The mesh is projected roughly onto a sphere

Optimisation The locations of the mesh points on the hemisphere is adjusted so as to minimise a
weighted sum of the squared differences between the lengths of links in the mesh on the hemi-
sphere and on the flattened retina, whilst ensuring that as few triangles as possible are flipped.

At the end of the reconstruction process, a polar plot appears next to the flattened retina. By default
the location of the full cuts and tears in the polar coordinates can be seen.

2.8 Assessing the quality of the reconstruction

It is important to assess the quality of the reconstruction. The choice of where to mark up tears can
affect this adversely, as can the rim angle.

One diagnostic is to view the strain in each mesh link by clicking on the Strain checkbox in the Edit
tab. When Strain is shown, the flat plot shows the strain in the links of the mesh using a colour code
from blue (compressed) to red (expanded). The polar plot is replaced by a scatter plot of the length
of links in the reconstructed object versus the length on the flattened object. The flat plot of a good
reconstruction will look mostly green, and in the scatter plot the points will lie close to the black line.

2.9 Selecting viewing options

To select viewing options click on the View tab. A number of options are now shown, grouped into a
number of sections:
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2.9.1 Show
In the Show section there are checkboxes that allow you to show various types of information:

Markup Locations of tears and the dorsal or nasal pole

Stitch Locations of how the algorithm has stitched tears (only visible after the reconstruction step)

Grid Lines of latitude and longitude projected back onto the flattened retina (only visible after the
reconstruction step) and grid lines are shown on the reconstructed retina

Landmarks Landmarks such as the optic disc

Points Locations of data points, such as the locations of beads of dye, which have been imported into
RETISTRUCT as described in Section 2.2.4

Point means Locations of the Karcher mean (mean in spherical coordinates) of each group of data
points

Point contours Kernel Density Estimate contours of the data points. By default, contours at 5%, 25%,
50%, 75% and 95% of the maximum density are shown. This can be changed by a command like
this at the R prompt:

options(contour.levels=c(5, 25, 50))

This command would cause the 5%, 25% and 50% contour lines to be displayed.

Counts Counts (for example of cells), represented by a number at the location at which the count was
made, which have been imported into RETISTRUCT as described in Section 2.2.5

Count contours Kernel Regression contours of the data counts. By default, contours at 5%, 25%, 50%,
75% and 95% of the maximum density are shown. This can be changed by a command, as shown
under “Point contours”.

2.9.2 IDs
If you included a datapoints.csv and/or a datacounts.csv file (see Sections 2.2.4 and 2.2.5) the IDs
section will contain checkboxes with names corresponding to the names of the groups of points and the
names of the groups of counts specified in those files. If you have marked the optic disc, it will also
contain an OD checkbox. Check or uncheck these boxes to show or hide the corresponding points and
counts.

2.9.3 Projection
The reconstructed data can be viewed in a number of projections, just as there are various ways that
the surface of the globe is projected to a 2D image. Because the geometry of the surface of a sphere
is fundamentally different from a flat sheet of paper, no projection is a perfect representation; all have
advantages and disadvantages.

Note: Coordinate systems
The co-ordinates of a point on the reconstructed sphere can be described in two ways:

Latitude and longitude Here latitude and longitude are defined analogously to the standard geo-
graphical coordinate system. We imagine the retina lying with its optic pole at the south pole,
and with its widest point lying on the equator. The latitude of the optic pole is −90◦ and the
latitude of point on the widest point of the retina (its “equator”) is 0◦. We denote the latitude ϕ
and the longitude λ.

Colatitude and longitude Here we imagine the retina in the same orientation with respect to the earth,
but we rather than latitude, we use colatitude measured from the south pole, i.e. the south pole
has a colatitude of 0◦ and the widest point (the “equator”) has a colatitude of 90◦. We denote
colatitude by ψ and it is related to latitude by ψ = ϕ + 90◦.
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Projection Latitude & longitude Colatitude & longitude
Azimuthal Equidistant ρ = 90◦ + ϕ, λ = λ ρ = ψ, λ = λ

Azimuthal Equal Area ρ =
√

2(1 + sin ϕ), λ = λ ρ =
√

2(1− cos ψ), λ = λ
Azimuthal Conformal ρ = tan (45◦ + ϕ/2), λ = λ ρ = tan (ψ/2), λ = λ
Sinusoidal x = (λ− λ0) cos ϕ, y = ϕ
Orthographic x = cos ϕ sin(λ− λ0)

y = cos ϕ0 sin ϕ− sin ϕ0 cos ϕ cos(λ− λ0)

Table 2.1: Projections. For the three azimuthal projections, the polar coordinates (ρ, λ) are given in
terms of the latitude and longitude (ϕ, λ) or colatitude and longitude (ψ, λ) on the original sphere.
For the sinusoidal and orthographic projection the (x, y) coordinates in the plane are given. For these
projections (ϕ0, λ0) is the latitude and longitude at the centre of the projection.

Currently the options are:

Azimuthal Equidistant The default projection. This is a polar plot in which the radial distance is pro-
portional to the colatitude (latitude measured from the “South Pole”; see note on coordinate
systems), and angle from the horizontal is equal to the longitude on the original retina. Points
equidistant on line of longitude are also equidistant in this projection. It is not an area-preserving
projection: it makes regions closer to the rim look bigger than they actually are relative to areas
close to the south pole.

Azimuthal Equal Area In this projection, also known as a Lambert projection, points that are equidis-
tant on lines of longitude on the spherical retina are not equidistant: points close to the rim are
mapped to be closer together. This is done so that area is preserved in the sense that equal ar-
eas on the sphere project to equal areas on the plane of projection. It is thus an area-preserving
projection.

Azimuthal Conformal In this projection, also known as a Wulff projection, angles are preserved. This
is done at the expense of expanding the representation of areas close to the rim.

Sinusoidal The sinusoidal projection projects the entire globe onto the plane and preserves area. The
user selects the longitude at the centre of the projection in the Az box in the Projection centre
section of the window. The sinusoidal projection is helpful for data transformed into visuotopic
space (see later).

Orthographic The orthographic projection gives a perspective view of one side of the globe. The pro-
jection is centred on a latitude and longitude specified by the values in degrees in the El and Az
boxes in the Projection centre section.

Note: Convention on longitude of nasal, dorsal, temporal and ventral poles
By convention, the polar plots are viewed as though the animal is facing towards the observer. This
means that when plotting a retina from a right eye, the nasal pole on the right and N, D, T, V are in
anticlockwise order; for a retina from a left eye, nasal is on the left and N, D, T, V are in clockwise order.
The longitude of a point was defined so that 0◦ is always at the right of the plot and 90◦ at top. This
means that for a right eye the poles correspond to the longitudes as follows: N, 0◦; D, 90◦; T, 180◦; V,
270◦. For a left eye the longitudes of the nasal and temporal poles are interchanged: N, 180◦; D, 90◦, T,
0◦; V, 270◦.

2.9.4 Transform
The Transform option allows the reconstructed retina to be projected into visual space. The options are

None (default) No transformation is made.

Invert The image is inverted as though by a pinhole lens, a crude approximation to the optics of the
eye. This allows visual space to be mapped onto the retina via the optical system of the eye. This
mapping depends on the angle that a ray makes with the optic axis (the Axis direction) which we
define as being oriented at azimuth (Az) and elevation (El).
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Invert to hemisphere Similar to Invert, except that the projection is compressed or expanded so that
the field of view is 180◦.

There are more details of the transformation in the supplemental information of [1].

2.10 Exporting the plots

The Bitmap and PDF buttons above the flat-mount view and the reconstructed view export the image
show to a PNG file format or an PDF respectively. To change the width of the image in pixels, select
Properties and set the Maximum width of projection to the desired number of pixels. Warning: setting
a high number of pixels will create a high-resolution image, but can also take some minutes.

2.11 Saving the reconstruction

To save the markup, click on the “Save” button in the toolbar. This saves various files to the directory
containing the data files. When the files in the directory are opened again, all the markup informa-
tion (cut locations, location of nasal point and rim angle) is loaded, and the reconstruction will also
appear, unless there has been a major upgrade of the software, in which case the retina will need to be
reconstructed using the “Reconstruct retina” button.



Chapter 3

Further topics

3.1 Accessing reconstruction data from R

It can be useful to have access to the data underlying a reconstruction directly, for example to allow
statistical analysis. To load saved date into R, type the following into R:

r <-

retistruct.read.recdata(list(dataset="/path/to/reconstruction/directory"),

check=FALSE)

The resulting object r contains various fields, which can be accessed using the R $ operator, e.g.

r$featureSets[[1]]$Ps

gives a list of the spherical co-ordinates of labelled data points. Other quantities (for example the loca-
tions of the mesh points in the flat and spherical retina) are also available.

All classes are fully documented - type ‘help.start()‘ and browse to the retistruct package. Then
the RetinalReconstructedOutline class is a good place to start.

3.2 Reading reconstruction data into MATLAB

By default when a reconstruction is saved, a subset of the data is stored in a file called r.mat in the same
directory as the raw data and the markup. To import this data into MATLAB, cd into that directory, and
type:

clear

load r.mat

This puts a number of variables into the workspace, as shown in Table 3.1.
To produce a polar plot of data points, try the following code:

polar(Dss.green(:,2), Dss.green(:,1)*180/pi+90, ’.g’)

hold on

polar(Dss.red(:,2), Dss.red(:,1)*180/pi +90, ’.r’)

hold off

The radial axis indicates the latitude in degrees measured from the retinal pole.
In the matlab subdirectory of the distribution, there are some scripts to produce polar polar plots,

including the locations of tears and landmarks. To create PDF plots of all the retinae in a directory, try:

makefigures(’retinae’, ’output_directory’)

There are also some embryonic scripts to create polar plots: plot datapoints polararea.m and
polararea.m.
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phi0 The latitude of the rim, expressed in degrees
Dss Structure containing locations of labelled cell bodies in spherical coordinates.

The first column contains the latitude of each point, measured in radians. The
second column contains the longitude of each point, measured in radians.

DssMean Location of Karcher mean of green-labelled cell bodies in spherical coordi-
nates. The first column contains the latitude of each point, measured in ra-
dians. The second column contains the longitude of each point, measured in
radians. A value of −2147483648 corresponds to NA in R.

DssHullarea, Structure containing area of convex hull of points on sphere. The convex hull
is essentially a polygon drawn around data points. A value of −2147483648
corresponds to NA in R.

Tss A structure in which each element contains spherical coordinates (in the same
latitude-longitude format as above) of a tear.

Sss A structure in which each element contains spherical coordinates (in the same
latitude-longitude format as above) of a landmark.

KDE An object containing information about Kernel Density Estimates of the loca-
tions of cell bodies.
green flevels Contour heights, determined by finding heights

that exclude a certain fraction of the probability.
For example, the 95% contour is excludes 95% of
the probability mass, and it should enclose about
5% of the points.

green labels Contour labels. These give the label (e.g. 5, 25, 50,
where these are the percentages above) of each
contour. Note that there may be more than one
contour at the same level, so this vector may con-
tain more elements than flevels. The first ele-
ment of green labels labels the contour whose
coordinates are specified in green contours1,
the second element of green labels relates to
green contours2 and so on.

green tot contour areas The total area in square degrees enclosed by each
contour. This is a matrix with the first column
giving the contour label (see above) and the next
column giving the area.

green kappa The concentration parameter of the Fisher density
determined by the kernel fitting algorithm.

green h A pseudo-bandwidth parameter, the inverse of
the square root of kappa. Units of degrees.

green maxs phi Lattitude of maximum point of kernel estimate.
green maxs lambda Longitude of maximum point of kernel estimate.
green g xs green g ys

green g f

Kernel density estimates on standard polar
grid. This can be plotted in MATLAB us-
ing the command contour(KDE.green g xs,

KDE.green g ys, KDE.green g f).
green gpa xs

green gpa ys

green gpa f

Kernel density estimates on area-preserving po-
lar grid. Plotted in MATLAB as above.

green contours1,
green contours2...

Coordinates of contours. See green labels

above for more explanation.
green contour areas1,
green contour areas2...

Area contained within each individual contour.
See green labels above for more explanation.

KR An object containing Kernel Regression estimates of the density of points, de-
rived from the grouped data points. All fields correspond to KDE above.

Table 3.1: Variables exported in the r.mat file.
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3.3 Running a batch of reconstructions

The RETISTRUCT library can be used to reconstruct a batch of retinae which have been marked up. Sup-
pose that the directory retinae contains a directory tree in which there are data directories containing
the raw outline, data point and image files and the saved markup files. In order to perform the recon-
structions, we create a new directory retinae/reconstructions, and run the following sequence of
commands in R:

R

> library(retistruct)

> retistruct.batch(tldir=’retinae’, outputdir=’retinae/reconstructions’)

This command will go through the retinae directory, looking for valid data directories. If it finds
one, it sets about trying to reconstruct the retina. As it reconstructing each retina, it writes to log file
in retinae/reconstructions. Once the reconstruction is complete, it saves a number of plots in this
directory in PDF format. It also adds a line to a summary log file in retinae/reconstructions called
retistruct-batch.csv. This file contains a number of columns:

Dataset The directory of the data set

Return The return value from the process

Result A summary of the result, including if any errors were returned

E The total error of the optimised reconstruction

El The error due to purely to the lengths of links in the optimised reconstruction

nflip The number of flipped triangles

EOD The distance of the Optic Disc from the inferred centre of the retina, in degrees. If the OD has not
been marked up, this is NA.

To export the reconstruction data in a directory hierarchy in which retistruct.batch() has been
run, run the following sequence of commands in R:

R

> library(retistruct)

> retistruct.batch.export.matlab(tldir=’retinae’)
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Appendix A

The IDT Data format

The data for each retina is stored in a separate directory. Within each directory there are two files:

SYS.SYS A table in SYSTAT format containing the coordinates of the red, green and doubly labelled
cell bodies, and counts of labelled cell bodies within each grid box. The column headings shown
in Table A.1. Each row of the table contains information only on a subset of the data, e.g. the
coordinates of a red-labelled cell.

ALU.MAP A text file containing the coordinates of the map outline. The file comprises a number of
sections, each starting with a single number, which is the number of lines to read in the next
section. These lines have two numbers each, the x and y coordinates of a vertex of the map
outline.
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FOR EACH BOUNDARY
MAPNUM id number of boundary
MINLAT min latitude
MAXLAT max latitude
MINLON min longitude
MAXLON max longitude
LABLAT latitude of label
LABLON longitude of label

FOR EACH CELL
XRED x-coordinate if cell labelled red but not doubly
YRED y-coordinate if cell labelled red but not doubly
XGREEN x-coordinate if cell labelled green but not doubly
YGREEN y-coordinate if cell labelled green but not doubly
XDOUBLE x-coordinate if cell labelled doubly
YDOUBLE y-coordinate if cell labelled doubly
XGRID sample box cell is in
YGRID sample box cell is in
PERIM perimeter of cell
AREA area of cell

ONE PER GRID BOX
GRIDX grid location of centre of sample box
GRIDY grid location of centre of sample box
XGRIDCOO x-coordinate of centre of sample box
YGRIDCOO y-coordinate of centre of sample box
BOXSIZEX size (half width) of sample box in x-direction
BOXSIZEY size (half width) of sample box in y-direction
COMPLETE whether counting of sample has been completed
TOTALCEL total number of cells in this box
TOTALRED total number of red-only cells in this box
TOTALGRE total number of green-only cells in this box
TOTALDOU total number of double cells in this box
MEANPERI average perimeter of all cells
MEANAREA average area of all cells

Table A.1: Column headings of the SYS.SYS file.
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